アナログ電子回路技術者同士の交流のためのアナログ・デバイセズ提供の掲示板サイトです。
日々の回路設計活動での課題や疑問とそれらの解決、あるいはご意見やご提案などの投稿を是非お寄せください!
  トップページに戻る
 現在の総記事数
 Translation
スタッフ
 

閲覧数の多い投稿

* ランキング情報は約24時間おきに更新されます。
ポイント数が高い投稿

* ランキング情報は約24時間おきに更新されます。

アナログ電子回路コミュニティサービス終了のお知らせ

平素はアナログ電子回路コミュニティをご愛顧いただき誠にありがとうございます。

この度、アナログ電子回路コミュニティは2018年3月末日をもってサービスを終了することとなりました。それに伴いまして、本サービスへの新規会員登録は2月末日をもって締切りといたします。約10年という大変長い間、たくさんの皆様にコミュニティをご利用いただきましたこと、深く感謝申し上げます。

なお、コミュニティに掲載しているコンテンツは編集の上、アナログ・デバイセズ社のウェブサイトに随時掲載していく予定です。詳細は追って会員の皆様にお知らせいたします。

今後ともEDN Japanをご愛顧くださいますようお願い申し上げます。


アナログ電子回路コミュニティ運営事務局
* LTC製品に関するご注意
申し訳ございませんが、現時点ではリニアテクノロジー社製品についてのお問い合わせは、リニアテクノロジー社の 技術サポートページ からお問い合わせください。

スレッド一覧に戻る

USK
タイトル
ADV7610 INT2が出力されない
ポイント []
pt.
アクセス1725
カテゴリーインターフェース&スイッチ
キーワード INT2 high when active   ADV7610 INT2   INT2ピン   SCLK   INT2 pin   Powered by Yahoo
投稿日時15/09/18 11:45
ADV7610のSCLK/INT2ピンをINT2として使用したく、以下の内容でレジスタを設定しています。

Address / 設定値
41h/32h(INT2 high when active / SCLK/INT2 pin)
72h/01h(CABLE_DET_A_MB2 = 1)

上記の設定でHDMIケーブルを抜くと、INT2割り込みが発生すると考えているのですが、SCLK/INT2ピンに変化が見られません。

SCLK/INT2ピンがOpenDrain出力だという情報を耳にし、プルダウンしていたところをプルアップに改造してみましたが、やはり信号に変化は見られませんでした。

CABLE_DET_A_STのbitは"1"となっているので、検出自体はしているようなのですが、それがINT2へ出力されていないように見えます。

※HDMIケーブルを抜く前にCABLE_DET_A_CLRでリセットは実施しています。

ADV7610のINT2を使用するに当たり、設定内容に抜けや誤りなどがあるでしょうか?

コメントする     


Braveman 回答番号 7
タイトル
個別対応中ということで
ポイント
pt.
アクセス1460
投稿日時15/10/05 16:44
USKさん、
こんにちは
先日お伝えした、弊社Tech Support窓口にて対応中でございますので、こちら一旦クローズということでお願い致します。ちなみに弊社では正常動作が確認されております。

よろしくお願い致します

Braveman 回答番号 6
タイトル
解決するかわかりませんが。。。
ポイント
pt.
アクセス1493
投稿日時15/09/28 11:51
USKさん、
こんにちは

どうもレジスタの設定はあってそうですので、解決するかどうか分かりませんが、

INTRQ_DUR_SEL[1:0]を11bでクリアされるまで出力にすると、どうでしょうか?

お試し頂けますでしょうか?
よろしくお願い致します

USK 回答番号 5
タイトル
ご連絡が遅くなり、申し訳ございません
ポイント
pt.
アクセス1622
投稿日時15/09/25 18:59
コメントありがとうございます。

Bravemanさん
ご確認、宜しくお願い致します。
なお、同じ質問をEngineerZoneでもさせて頂いており、ADIのエンジニアの方から下記アドバイスを頂いたのですが、やはりINT2は出力されませんでした。

Set INTRQ_DUR_SEL = 11, 0x40 = E2

before setting 0x72, clear CABLE_DET_A_CLR by writing 0x71 = 0x01;

教えて頂いたTech Supportにも問い合わせをしてみようと思います。


IKUZOさん
代理店経由でサポートを受けているのですが、これが中々フットワーク重く…。INT1は既に別の用途で使用しているので、一先ず回答を待ってみようと思います。

Braveman 回答番号 4
タイトル
すみません、少しお時間ください
ポイント
pt.
アクセス1601
投稿日時15/09/22 21:59
USKさん、
こんばんは

すみません、こちら確認したいと思いますので少しお時間ください。

なお、お急ぎの場合はTech Supportという窓口をホームページにて開設してありますので、そちらをご利用になられることをお勧め致します。
http://www.analog.com/jp/support/landing-pages/003/jp-tech-support.html

よろしくお願い致します

IKUZO 回答番号 3
タイトル
INT1では正常なのに
ポイント
pt.
アクセス1606
投稿日時15/09/19 08:56
USK さん
思いどうりにならなくて残念ですね、サポートはしてくれていますか?投稿されるくらいだから、時間がかかっているのでしょうね、
開発現場としてはその日のうちに回答が得たいですよね、このさいINT1に配線を変えるか、ポーリングで取り合えず対応しておき、スタッフさんの回答待ちでしょうね、

USK 回答番号 2
タイトル
拝見いたしました。
ポイント
pt.
アクセス1722
投稿日時15/09/18 19:32
IKUZOさん

アドバイス頂きありがとうございます。

ご指摘頂いたレジスタを拝見いたしましたが、残念ながらINT2が出力されない件とは関係がなさそうです。

アドレス3FhのINTRQ2_RAWのbitには"1"(=INT2割り込みイベント発生)が立っており、ADV7610はINT2割込みが発生していると認識しているようです。

INT1で同様に設定をすると正常にINT信号を出力するのですが、なぜかINT2では出力してくれません…。

IKUZO 回答番号 1
タイトル
UG-438.pdfの
ポイント
pt.
アクセス1616
投稿日時15/09/18 12:32
Function CABLE_DET_A_RAW Description
0 (default) No cable detected on Port A
1 Cable detected on Port A (high level on RXA_5V)

Function FILT_5V_DET_DIS Description
0 (default) Enabled
1 Disabled

とありました、関係ないですか?

検出はできているようだ、とありますので別の箇所でしょう

スレッド一覧に戻る



コメント投稿

* コメントの投稿にはログイン(ユーザー登録)が必要です。


タイトル

* 50文字以内
『初心者でも大丈夫!』
(記事の内容が初心者向けの場合はここにチェックをしてください。)
本文

* あと6000文字

ファイル1
ファイル2
ファイル3

* 5MBまでのGIF, JPEG, PDF ファイルが投稿できます。

* 入力に時間がかかると、セキュリティのためにログイン情報が破棄されて書き込みが処理されないことがあります。投稿内容確認ボタンを押す前に、一旦文章をクリップボードにコピー(本文入力欄をクリック後Ctrlキー+A、Ctrlキー+Cと連続で押す)して、再貼り付けできるようにしておいて下さい。

ゲスト 様
投稿する場合はログインして下さい。 初めての方はこちらからご登録ください。

お知らせ
ユーザーランキング

* ランキング情報は約24時間おきに更新されます。


  個人情報保護方針会社情報お問い合わせ

copyright(c) 2010 - 2017 ITmedia Inc.